problem starting DSA in Ubuntu 20.04 VMM


I Have tried to move DSA into a Ubuntu VMM. Waiting for girder to report version results in

python3 start
Creating rabbitmq:management - dsa_rabbitmq
Starting rabbitmq:management - dsa_rabbitmq
Creating mongo:latest - dsa_mongodb
Starting mongo:latest - dsa_mongodb
Creating memcached:latest - dsa_memcached
Starting memcached:latest - dsa_memcached
Creating dsarchive/dsa_worker:latest - dsa_worker
Starting dsarchive/dsa_worker:latest - dsa_worker
Creating dsarchive/dsa_girder:latest - dsa_girder
Starting dsarchive/dsa_girder:latest - dsa_girder
Waiting for Girder to report version: …Traceback (most recent call last):
File “/usr/local/lib/python3.8/dist-packages/docker/api/”, line 268, in _raise_for_status
File “/usr/lib/python3/dist-packages/requests/”, line 940, in raise_for_status
raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 409 Client Error: Conflict for url: http+docker://localhost/v1.41/containers/5a4bc6fd068c6ffcb5f6fca060ad6a5e6b4f05cd6b7a31d0a4d25c838c71a755/exec

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “”, line 1075, in
File “”, line 192, in containers_start
File “”, line 123, in containers_provision
wait_for_girder(client, ctn)
File “”, line 883, in wait_for_girder
cmd = client.exec_create(
File “/usr/local/lib/python3.8/dist-packages/docker/utils/”, line 19, in wrapped
return f(self, resource_id, *args, **kwargs)
File “/usr/local/lib/python3.8/dist-packages/docker/api/”, line 78, in exec_create
return self._result(res, True)
File “/usr/local/lib/python3.8/dist-packages/docker/api/”, line 274, in _result
File “/usr/local/lib/python3.8/dist-packages/docker/api/”, line 270, in _raise_for_status
raise create_api_error_from_http_exception(e)
File “/usr/local/lib/python3.8/dist-packages/docker/”, line 31, in create_api_error_from_http_exception
raise cls(e, response=response, explanation=explanation)
docker.errors.APIError: 409 Client Error for http+docker://localhost/v1.41/containers/5a4bc6fd068c6ffcb5f6fca060ad6a5e6b4f05cd6b7a31d0a4d25c838c71a755/exec: Conflict (“Container 5a4bc6fd068c6ffcb5f6fca060ad6a5e6b4f05cd6b7a31d0a4d25c838c71a755 is restarting, wait until the container is running”)
kai@dsa-intern:~/digital_slide_archive/ansible$ docker ps
5a4bc6fd068c dsarchive/dsa_girder:latest “/bin/sh -c 'sudo -E…” 4 minutes ago Up 24 seconds>8080/tcp, :::8080->8080/tcp dsa_girder
9fb2b59804c3 dsarchive/dsa_worker:latest “/bin/sh -c 'sudo -E…” 4 minutes ago Up 4 minutes dsa_worker
ebe618224bca memcached:latest “docker-entrypoint.s…” 5 minutes ago Up 4 minutes 11211/tcp dsa_memcached
1281424d3571 mongo:latest “docker-entrypoint.s…” 5 minutes ago Restarting (132) 39 seconds ago dsa_mongodb
1934c8f0c67f rabbitmq:management “docker-entrypoint.s…” 5 minutes ago Up 5 minutes 4369/tcp, 5671-5672/tcp, 15671-15672/tcp, 15691-15692/tcp, 25672/tcp dsa_rabbitmq

What may be the cause of this problem?

Best regards,


It is hard to tell from what you posted. It shows “Client Error: Conflict for url” which could have a variety of causes (do a search for “Docker Client Error: Conflict for url” to see some of them). Possibly docking “docker logs dsa_girder” would show a more useful error message.

the problem was mongo:latest which requires a CPU with AVX support. This failed silently if the processor does not supply AVX (for example my Synology DS420+). Changing mongo:latest to mongo:4.4.6 solves this problem.

Best regards


Thanks for reporting the resolution. I expect that looking at the mongo container’s logs would have shown this error.

yes but I am working as a pathologist and I am new to docker and/or web technologies. But I have tried the docker-compose example as well and there the problem is clearly shown.